[Robot-Framework][SikuliLibrary] Timeout Not Finding img


I’m wokring with:

Python (version : Python 3.10.4)
RobotFramework (version: 6.1.1)
robotframework-SikuliLibrary (version 2.0.3)
OS: Windows

I’m trying to make the hello world example : Sikuli Robot Framework Library | robotframework-SikuliLibrary.

I have an error :

com.github.rainmanwy.robotframework.sikulilib.exceptions.TimeoutException: Timeout happened, could not find P(1701437608400.png – not valid!) S: 0.7

I manage to understand that S is for “Similarty”. meaning that the program can find a 70% chance my image ?

Another issue I have is that I don’t understant why there is a need capture pics if I can get them. Currently all the script is picking up is the IDE with the script… not really interesting!

I have passed him my pic (in the folder the scripts creats and out)…

Nothing changes.

I have many “Sikuli_java_stdout_1701446696.1746387.txt” file with the same message :

WARNING: sun.reflect.Reflection.getCallerClass is not supported. This will impact performance.
17:04:56.823 [main] INFO org.eclipse.jetty.util.log - Logging initialized @517ms to org.robotframework.remoteserver.logging.Jetty2Log4J
17:04:56.895 [main] INFO org.eclipse.jetty.server.Server - jetty-9.4.31.v20200723; built: 2020-07-23T17:57:36.812Z; git: 450ba27947e13e66baa8cd1ce7e85a4461cacc1d; jvm 19.0.2+7-44
17:04:56.947 [main] INFO org.eclipse.jetty.server.handler.ContextHandler - Started o.e.j.s.ServletContextHandler@69c81773{/,null,AVAILABLE}
17:04:57.090 [main] INFO org.eclipse.jetty.server.AbstractConnector - Started ServerConnector@770d3326{HTTP/1.1, (http/1.1)}{}
17:04:57.090 [main] INFO org.eclipse.jetty.server.Server - Started @794ms

Same message as when I run the command :

“java -jar SikuliLibrary.jar 1000”

my code :

*** Settings ***
Documentation Sikuli Library Demo
Library SikuliLibrary
Library BuiltIn

*** Test Cases ***
Windows Notpad Hellow World
Open Windows Start Menu
Open Notepad
Input In Notepad
Quit Without Save

*** Keywords ***

Set Always Resize = 5

Open Windows Start Menu
Click 1701437608400

Open Notepad
Input Text search_input.png notepad
Click notepad.png
Double Click notepad_title.png

Input In Notepad
Input Text notepad_workspace.png Hello World
Text Should Exist Hello World

Quit Without Save
Click close.png
Click dont_save.png

Can I pass my program image and skip the capture?

How can I make the hello world work ?

Is there another documentation for installing the Lib



edit : here is the txt file I have :

I have asked @raiman here : Question #708594 “[Robot-Framework]Timeout Not Finding img” : Questions : SikuliX :slight_smile:

Hi @TextSolver34761,

Try this:

*** Test Cases ***
Windows Notpad Hellow World
    Add Image Path    ${CURDIR}
    Open Windows Start Menu

FYI - Add Image Path

The error message seems to be saying that the file 1701437608400.png is not valid, probably that it couldn’t find it?

Using Add Image Path should help with that, if it still doesn’t work it could also be that the file format of the image is invalid?

Hope that helps,


Hi @damies13 ,

Thanks, it worked!.

As you can see, the image captured by the program is a full page screenshot (and not my windows button).

I don’t understand why.



1 Like

Hi @TextSolver34761,

Sikuli only looks in the directories that it’s told to look in by that keyword, it doesn’t seem to be mentioned in the documentation but you’ll see all the examples on the github page use this keyword before anything else.

Also as a tip, try to make the images you want to match as small as possible while still uniquely identifying the area.

for example this will give you a better match:

than this:

Hope that helps,