NoSuchDriverException: Message: Unable to obtain driver for MicrosoftEdge using Selenium Manager

While running script am getting following error.

" NoSuchDriverException: Message: Unable to obtain driver for MicrosoftEdge using Selenium Manager "

Kindly help me on this issue.

Hi Vishnuvardhan,

As far as I know Edge is not supported in Browser Library?

Are you using Browser Library or SeleniumLibrary? because you posted this in the Browser Library section.

Need to clarify so we can give the right advise.


Am using Selenium library

You are in wrong channel, you should post in SeleniumLibrary channel.

FYI switching categories is possible. So no repost in SeleniumLibrary is needed. I moved it.

1 Like

Have you found any solution for this issue? I got the same issue today and tried reinstalling the packages, webdrivers and even tried setting up the environment once again from scratch. Still haven’t found any solution for this.

Hi Kasun,

You need to install a webdriver for Edge, just like Chrome, Firefox, etc, also make sure Selenium can find the webdriver (you may need to make sure it’s in the path)

The error message is telling you the problem.


Hi Dave,

thanks for the quick reply. I have done those things as well. I am getting same error for both Firefox and chrome too. And also I have again updated the path for webdrivers too. only this machine gets this error. that’s what’s bugging me.

Might be worth providing the path your setting and the surrounding statements and a snippet of the placement of those drivers within its folder, and the error you are being returned if possible.

It does sound more path related if it is just this machine


Hi Daryl,

I will attach the screenshots below

Error log file

Webdrivers location

Hi Kasun,

After you added C:\bin to your path di you close the command window and re-open it before running robot again?

FYI - Windows command window doesn’t update the path dynamically, it gets the path when it’s opened and continues with that path value until it’s closed.

If you are running with pycharm (I saw that in your path) then try closing pycharm and re-open it.


Also, there was another thing with the chrome driver. the browser has updated to its latest version which is
120.0.6099.200 now and we only can get version 120.0.6099.109 for the Chrome driver because it’s the only one available at the moment. will that be a problem? if so any other way to get the updated driver version?
We have several machines that we are running this Robot Framework same code. but only this computer got this issue when we are setting up for the automation.

Most of the time as long as the first three parts of the version number are the same it should work fine (120.0.6099.109)

This is always an issue with Selenium Library, I posted an option to auto-update the web driver here: Error with Chrome version 115 and newer - #26 by damies13
I’ve not tested it with Edge but you could adapt it for Edge and try it, hopefully it will work :crossed_fingers:


Hi Everyone,

We have resolved the issue. Thanks for your support & valuable suggestion. The issue was since it was a company laptop, the administrator was someone else and in such cases, we had to create a bin folder in the users folder. We didn’t know it before. When we created that folder, the issue was resolved if someone experiences the same issue though this might be useful. I used the below steps to resolve that issue.

  1. Create the bin folder in this location & copy the web drivers there -

  2. Add that exact path to the Environmental Variables - C:\Users[username]\AppData\Local\bin

  3. Add the executable path to your script and add the bin folder full path there