wxWidgets Debug Alert

Hi while opening ride.py on robot framework getting , please help me thanks


Very little information.

I see it is Windows system.
What version of Python, RIDE and wxPython?
What you did before getting the error message?
What happen if you click Cancel?

Hi, Thanks for your reply
I am using Python37,
pip 21.2.1

I just click on Ride and getting above message

if i click cancel close popup but not able to open ride

pip - 21.1.1

Commands you can show us:

pip show robotframework-ride
pip show wxPython

Thanks, RIDE Version -
wxPython Version - 4.0.7
pip 21.1.1

Thanks, please advise

further stack trace are below:

Traceback (most recent call last):
File “c:\users\lvenugopal003\appdata\local\programs\python\python37\lib\site-packages\robotide\application\application.py”, line 74, in OnInit
wx.CallLater(200, ReleaseNotes(self).bring_to_front)
File “c:\users\lvenugopal003\appdata\local\programs\python\python37\lib\site-packages\wx\core.py”, line 3329, in init
File “c:\users\lvenugopal003\appdata\local\programs\python\python37\lib\site-packages\wx\core.py”, line 3350, in Start
self.timer.Start(self.millis, wx.TIMER_ONE_SHOT)
wx._core.wxAssertionError: C++ assertion “wxThread::IsMain()” failed at …\src\common\timerimpl.cpp(60) in wxTimerImpl::Start(): timer can only be started from the main thread
OnInit returned false, exiting…
Error in atexit._run_exitfuncs:
wx._core.wxAssertionError: C++ assertion “GetEventHandler() == this” failed at …\src\common\wincmn.cpp(478) in wxWindowBase::~wxWindowBase(): any pushed event handlers must have been removed

Please install the current Beta version, with:

pip install psutil
pip install -U --pre robotframework-ride

See other options on GitHub - robotframework/RIDE: Test data editor for Robot Framework

Thanks for your reply, after installing current Beta version also, i am getting same error

Try the correct version of wxPython:

pip install -U wxPython==4.0.7.post2

running out of ideas.
did you restarted the system?
did you installed with Administrator rights?

Thanks for your replies , finally i have got resolved error
i have deleted existing project also, then it worked