Old RIDE 1.2 doesn't launch after installing new robotframework6

We have several machines in our team with the same configurations:
robotframework==2.8.1
robotframework-ride==1.2.2 (or 1.2.3)
wx.version()
‘2.8.12.1 (msw-unicode)’
and they all work, some of them have 2 pythons ( 2 and 3) and 2 robots and rides (2.8.1/1.2 and 5/1.7.4), but none had the latest ride 2 and latest robot 6 combination.

Now I’ve uninstalled both pythons, robots,ride.
And reinstalled python 2.7, robot 2.8.1 and ride 1.2.3.

When I run python c:\Python27\scripts\ride.py
empty folder C:\Users\Admin\AppData\Roaming\RobotFramework\ride\library_xmls\ gets created,
but ride doesn’t launch:
d:\Python27>python2 d:\Python27\Scripts\ride.py

d:\Python27>

I’ve tried reinstalling different version of (2.8.1-2.8.6) and ride (1.2/1.3)
but I get the same situation:
empty folder C:\Users\Admin\AppData\Roaming\RobotFramework\ride
gets created with empty library_xmls subfolder.
and ride doesn’t launch. (edited)

when I try to install ride 1.3 from windows installer I get this error
Traceback (most recent call last):
File “”, line 3, in
File “C:\Python27\lib\lib-tk\Tkinter.py”, line 38, in
import FixTk
File “C:\Python27\lib\lib-tk\FixTk.py”, line 65, in
import _tkinter
ImportError: DLL load failed: The specified module could not be found.

The funny thing is - when I run:
python
import wx
from robotide import main
on a maching with working ride
I still get

import wx
from robotide import main
Wrong wxPython version.
You need to install wxPython 2.8 toolkit with unicode support to run RIDE.
See http://wxpython.org for more information.

but ride 1.2.1 actually works on this machine

and
when I run:
python -m robotide.init %*
I get the same errors:
Traceback (most recent call last):
File “C:\Python27\lib\runpy.py”, line 162, in run_module_as_main
main”, fname, loader, pkg_name)
File “C:\Python27\lib\runpy.py”, line 72, in run_code
exec code in run_globals
File "C:\Python27\lib\site-packages\robotide_init
.py", line 135, in
main(sys.argv[1:])
File "C:\Python27\lib\site-packages\robotide_init
.py", line 76, in main
run(inpath, not noupdatecheck, debug_console)
File "C:\Python27\lib\site-packages\robotide_init
.py", line 95, in _run
inpath = unicode(inpath, sys.getfilesystemencoding())
TypeError: coercing to Unicode: need string or buffer, list found

on a machine with working ride 1.2.1

I gave that example to be run on a windows .bat or .cmd file. When running on command window, you must not use the %*, but the actual arguments you need.

For example:

python -m robotide.__init__  my_test_suite.txt

The topic mentions Robot Framework 6. Note that Python 2 is no longer supported by Robot Framework 6 and higher. You will need to upgrade to a recent Python version going forward.

I see, but it doesn’t matter:
when I run
python -m robotide.init
on a machine with working ride 1.2.1 - ride launches normally.

UPD:
and on my machine after I completely reinstalled python 2.7,wxpython,ride
when I run
C:\Users\Admin>python -m robotide.init

I get error:
c:\Python27>python -m robotide.init
c:\Python27\python.exe: No module named robotide.init

and when I try to run it with full path:
“python c:\Python27\Lib\site-packages\robotide\init.py”
nothing happens:
“c:\Python27>python c:\Python27\Lib\site-packages\robotide\init.py”

c:\Python27>

when I try installing later version using windows installer
robotframework-ride-1.4.1.win-amd64.exe
I get this error in the end:

and then these errors:
Traceback (most recent call last):
File “”, line 3, in
File “C:\Python27\lib\lib-tk\Tkinter.py”, line 38, in
import FixTk
File “C:\Python27\lib\lib-tk\FixTk.py”, line 65, in
import _tkinter
ImportError: DLL load failed: A dynamic link library (DLL) initialization routine failed.

and same errors with robotframework-ride-1.3.win-amd64.exe

when trying to run ride 1.2.3