Lauching Ride gives error message

When I am typing “ride.py” in command line, I get this error message: "<class ‘robotide.preferences.configobj.UnreprError’> Parse error in value at line 70.
<class ‘robotide.preferences.configobj.UnreprError’> Parse error in value at line 71.
<class ‘robotide.preferences.configobj.UnreprError’> Parse error in value at line 13.
Traceback (most recent call last):
File “c:\program files\python38\lib\site-packages\robotide\application\application.py”, line 58, in OnInit
self.frame = RideFrame(self, self._controller)
File “c:\program files\python38\lib\site-packages\robotide\ui\mainframe.py”, line 175, in init
self._init_ui()
File “c:\program files\python38\lib\site-packages\robotide\ui\mainframe.py”, line 279, in _init_ui
self.tree = Tree(self, self.actions,
File “c:\program files\python38\lib\site-packages\robotide\ui\tree.py”, line 86, in init
self._images = TreeImageList()
File “c:\program files\python38\lib\site-packages\robotide\ui\images.py”, line 42, in init
TestCaseController: _TreeImage(self, ‘robot.png’),
File “c:\program files\python38\lib\site-packages\robotide\ui\images.py”, line 80, in init
self.normal = self._get_image(image_list, normal)
File “c:\program files\python38\lib\site-packages\robotide\ui\images.py”, line 91, in _get_image
img = wx.Image(path, wx.BITMAP_TYPE_PNG).ConvertToBitmap()
wx._core.wxAssertionError: C++ assertion “strcmp(setlocale(LC_ALL, NULL), “C”) == 0” failed at …\src\common\intl.cpp(1579) in wxLocale::GetInfo(): You probably called setlocale() directly instead of using wxLocale and now there is a mismatch between C/C++ and Windows locale.
Things are going to break, please only change locale by creating wxLocale objects to avoid this!
OnInit returned false, exiting…
Error in atexit._run_exitfuncs:
wx._core.wxAssertionError: C++ assertion “GetEventHandler() == this” failed at …\src\common\wincmn.cpp(478) in wxWindowBase::~wxWindowBase(): any pushed event handlers must have been removed
"
How to fix this? I have just installed Python, Robotframework and this Ride.

Can’t tell what is going on. Would like to confirm it installed wxPython 4.0.7post2.

Please try to install the Beta version of RIDE 2.0, with:

pip install psutil
pip install -U --pre robotframework-ride
1 Like

Yes, thank You. This fix the problem.