Using AutoItLibrary or FLAui of Robot Framework Libraries with Pycharm IDE

I recently started test automation. My project involves automating tests on Windows applications (App.exe). I discovered Robot Framework and started using it with PyCharm IDE. I found that the AutoItLibrary and FLAui libraries can meet my needs. I started with AutoItLibrary (pip install robotframework-autoitlibrary).
On PyCharm, I have configured my interpreter correctly, but when I try to install the AutoItLibrary package, an error message appears.

When trying to run my script, I encounter FAILs indicating that the keywords are not found.

I am using Python 3.12 on Windows 11.

I’m open to any help regarding this matter.

Thank you in advance!

the version you are trying to install is intended for Python 2 and fails because of that.

robotframework-autoitlibrary has been updated to work with python3 so you are getting old version from somewhere ? You have a local package cache like Artifactory in use ?

No, I’m not using any local package cache. What is the version of AutoItLibrary that works with Python 3?

Is it useful to have a local package cache?
For python 3, would I use AutoItLibrary3?

I wasnt talking about local package cache, i was talking about possible pip mirror or forced http proxy.

Anyhuu, latest robotframework-autoitlibrary is 1.2.8 and it installs just fine on python 3.12.3 on windows 11.

Im still convinced that the issue is not with the package itself but how and where the package that comes when you are installing it… or you have requested older version of the package…

Thank you for your response.
Yes, I have indeed installed that version (1.2.8). So, I think I installed it incorrectly.

Just that I don’t understand why I can import the library but the keywords can’t be found.

Try doing an uninstall and then install again with -U (upgrade option to make sure it installs the newest version)

pip uninstall robotframework-autoitlibrary
pip install -U robotframework-autoitlibrary

Occasionally I’ve had a bad install of a module (very rare) and this fixed it for me.


Thank you for your response.
I have tried it but it doesn’t resolve my issue.

Make sure you run the installation command with administrative privilages.

1 Like


I am using the same libraries for my .exe applications. Uninstall the 3.12 and install the stable version of 3.10. Make sure you have included the Python path in the Windows environmental variables.

Restart your PC and try again.

In case you have the same issue, uninstall and install again the autoitlibrary.

Restart your PC and try again.

1 Like

Hello, are you using windows 64 bits ? I’m using the same version of robotframework-autoitlibrary on a 64bit windows and I’ve found there is an issue installing the correct DLL. When I do pip install it install and register the 32 version of the DLL instead of the 64 bit.

Can you try this ?
Unpack the AutoItLibrary3 in your Download folder (or anywhere else)

regsvr32.exe /U “C:\Program Files\Python310\Lib\site-packages\RobotFramework\Extensions\AutoItLibrary\AutoItX3.dll”

copy C:.…\robotframework-autoitlibrary-1.2.8\3rdPartyTools\AutoIt\lib64\AutoItX3.dll “C:\Program Files\Python310\Lib\site-packages\RobotFramework\Extensions\AutoItLibrary”

regsvr32.exe “C:\Program Files\Python310\Lib\site-packages\RobotFramework\Extensions\AutoItLibrary\AutoItX3.dll”



1 Like