Desktop automation Using Robot framework

Can anyone provide a source to any documentation for automating desktop apps using Robot framework in pycharm IDE? (2022 community edition) Most of the internet sources which i have found so far seems outdated. Basically my requirement is simple as follows:

  1. Open a Desktop app
  2. Click on a Button in the app
  3. Copy a Value from the app and store it in a variable

Tried approaches for installing the autoitlibrary

  1. pip install robotframework-autoitlibrary (using command prompt in non administartor mode)
    RESULT: AutoItlibrary installed successfully. But on running the Testcases which uses the Library error generated as pycharm Initializing library ‘AutoItLibrary’ with no arguments failed: com_error: (-2147221164, ‘Class not registered’, None, None)

  2. pip install robotframework-autoitlibrary (using command prompt in Administartor mode)
    RESULT: Error as follows

Using cached robotframework-autoitlibrary-1.2.8.tar.gz (696 kB)
Preparing metadata (setup.py) … error
error: subprocess-exited-with-error

× python setup.py egg_info did not run successfully.
│ exit code: 1
╰─> [8 lines of output]
Traceback (most recent call last):
File “”, line 2, in
File “”, line 34, in
File “C:\Users\coksoftware\AppData\Local\Temp\pip-install-4o16w6sn\robotframework-autoitlibrary_1e2046f1bb1947f38a47862d6e408c16\setup.py”, line 105, in
root_path = os.path.join(os.getenv(“HOMEDRIVE”))
File “C:\Users\arjun.s\AppData\Local\Programs\Python\Python310\lib\ntpath.py”, line 78, in join
path = os.fspath(path)
TypeError: expected str, bytes or os.PathLike object, not NoneType
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Any help would be appreciated

Second error (running as administrator) could point out that the environment variable “HOMEDRIVE” is not set.

you could try:

set HOMEDRIVE="C:" 

and then do the pip install stanza (in the same cmd session!) - that should fix the issue with TypeError but will most likely show up more issues down the line…

the issue with the com_error sounds a bit like pywin32 not installed or working properly. Dunno much about that.

@rasjani Thanks for your reply.

I have tried your solution #1 above. Now I have got the installation issue resolved , but still not able to run the desktop app, (Getting same error which I mentioned in #1 issue of my post)