Robotframework and Autoit Library

I am using now robotframework V7 I am trying to use Autoitlibrary for uploading a file in windows GUI.

I cannot find alot of keywords used to have them before in autoit library like “Send” as example.

I am not where is the problem. Is this library not supported anymore?

Hi @profrivo,

What do you mean by “I cannot find alot of keywords used to have them before”?

  • Do you mean the auto-complete in your editor is not working for these keywords now?
  • Do you mean that your editor is highlighting them as not available?
  • Do you mean the test fails because robot framework can’t find the keywords?

The first 2 are not really robot framework issues but rather your editor or the plugin for your editor, so perhaps mention the editor and any plugins you are using?

The third could be a compatibility issue with RF7, which version of RF were you using before?


Thanks for your reply. I mean that Send is not in the list of available actions. Please check this image.

I was using this 2 years before so for sure it was version before version 7

Anyone please can help me in this?

Hi @profrivo,

You could try typing Send and seeing if your test runs and passes, just to confirm where the issue is.

FYI - that list is not Robot Framework functionality, it’s part of your editor, sorry I’m not familiar with that editor, is it pycharm? (just a guess from the task bar icon)

Also I noticed you appear to have Python 3.6? Robot Framework 7 required Python 3.8 or higher

From the releasenotes:

Python 3.6 and 3.7 are no longer supported

Robot Framework 7.0 requires Python 3.8 or newer (#4294_). The last version
that supports Python 3.6 and 3.7 is Robot Framework 6.1.1.

So that may be related to your issue?


What do you mean by “I cannot find alot of keywords used to have them before”?

AutoIt lib for RF uses win32’s com bridge to talk to the actual autoit implementation. First robotframework-autoitlibrary/src/AutoItLibrary/ at master · nokia/robotframework-autoitlibrary · GitHub and then gets a list of methods within that com object; robotframework-autoitlibrary/src/AutoItLibrary/ at master · nokia/robotframework-autoitlibrary · GitHub that are exposed as keywords.

Problem is most likely either dll of autoit or python’s win32com and/or combination of possible os revisions …

@profrivo did you install robotframework-autoitlibrary as Administrator ? seems to require that as it does regsrv32 on the dll …

Having said that, even after registering the AutoItX3.dll on my system, I’m still facing similar issues as described in this issue; Initializing test library failed - Class not registered · Issue #31 · nokia/robotframework-autoitlibrary · GitHub

You could try to run the regsvr32 command mentioned in the issue too if that sorts out your problem.

This may be helpful:

1 Like

It seems to be IDE/plugin problem. It shows that keyword not found, however when I ran my script everything worked as expected.

I am using Pycharm with intellibot as plugin

Please be aware that the intelliBot plugin doesn’t seem to have been updated since nov 2022 according to: GitHub - lte2000/intellibot: IntelliJ/PyCharm plugin for Robot Automation Framework

For Pycharm there is the option to change to the robotframework-lsp plugin, but that one is incompatible with robotframework v7.0.

Another, but quite disruptive, option is to change IDE to VSCode with the robotcode plugin.
(Disclaimer, I haven’t tried whether that would fix your problem)