SeleniumLibrary Not Found, Package has been installed though

“resource”: “/Users/susmetanepal/Desktop/Robot/123.robot”,
“owner”: “generated_diagnostic_collection_name#2”,
“severity”: 8,
“message”: “Unresolved library: SeleniumLibrary.\nError generating libspec:\nImporting library ‘SeleniumLibrary’ failed: ModuleNotFoundError: No module named ‘SeleniumLibrary’\nConsider adding the needed paths to the "robot.pythonpath" setting\nand calling the "Robot Framework: Clear caches and restart" action.”,
“source”: “robotframework”,
“startLineNumber”: 3,
“startColumn”: 12,
“endLineNumber”: 3,
“endColumn”: 27

I have already installed it, but still not working.
Could someone please guide me through this?

Hi Sume,

Usually when i’ve seen something like this it’s because you have both Python 2.x and python 3.x on the same machine, but It could also happen if you have two different versions of python 3.x on the same machine.

If this is the case you need to make sure when you installed SeleniumLibrary you used the same pip/python version as when you installed robotframework

  • pip = usually python 2.x
  • pip3 = usually python 3.x

If this sound’s like your problem and need more help figuring out which python version each module is installed into just ask here.


When installing Seleniumlibrary, I used pip3. My python version is 3.10.8.
When i check the packages installed using pip3 list, it shows robot framework & robotframework-seleniujm library. Could I please get some guidance on how to install it correctly and make it function?
Thank you

Hi Sume,

Unfortunately i’ve never needed to troubleshoot this library, it’s always just worked for me, on a clean install I usually do the following:

pip3 install -U robotframework
pip3 install -U robotframework-seleniumlibrary
pip3 install -U webdrivermanager
webdrivermanager <browsername>

Basically just follow the installation instructions

if you’ve done that, then and it’s still not working then log an issue with the developers

Sorry I can’t help more than that,