Robotframework-RIDE - Keyword auto populate/suggestion is not working

Hi I am using “RIDE v2.0.8.1 running on Python 3.12.3.”

You should not use version in Python 3.12, because it was released before Python 3.12 existed.

tell me which RIDE version I have to use? and how we can install specific RIDE version?

Or tell me combination of RIDE and python version?

You can install the development version with:

pip install -U

But you should know the project page at GitHub - robotframework/RIDE: Test data editor for Robot Framework and take a look to the existing Issues.

I run the first test case but getting error

There is a problem with the formatting of the test suit, because it did not find tests.
You should paste here the text, using the code format, of the test suite/test case (after removing confidential data). Using text is preferable, because we can try to replicate the error.

*** Settings ***
Library SeleniumLibrary

*** Test Cases ***
openbrowser chrome

Here is your test case and screen captures:
TestSuite1.robot (134 Bytes)

Thank you for the help
It worked for me.
I was using TXT as Suite format instead of ROBOT.

but browser is closing automatically after test ends.

Still i am not getting keyword auto suggestions.

In Text Editor you use Ctrl-SPACE to activate keywords suggestions, same in Grid Editor if auto option is not active.

keywords like open browser, input text etc… are not in the list if we press ctrl+spacebar
but still they are working.

Something strange with your setup. Robot maybe running from a different python installation, than the one you have RIDE and libraries, like SeleniumLibrary.
You should see if there are errors on the import of the library in Tools->View RIDE Log.

This is the RIDE log

Robot Framework version 6.1.1 from c:\users\dell\appdata\local\programs\python\python37-32\lib\site-packages\robot.

RIDE using python version 3.7.9 with wx version 4.0.7.post2 in win32.

RIDE has a bug in documentation, like you found.

That is why we use upgraded versions!

please suggest me specific RIDE version.

and also telll me Python and wxPython version.

This version is OK.
You were not using this one, when you started this thread!

1 Like

Error : InsecureRequestWarning: Unverified HTTPS request is being made to host.
trying to execute POST method but getting error

Get_User_Info .C:\Users\Dell\AppData\Local\Programs\Python\Python312-32\Lib\site-packages\urllib3\ InsecureRequestWarning: Unverified HTTPS request is being made to host ‘’. Adding certificate verification is strongly advised. See: Advanced Usage - urllib3 2.2.2 documentation

My script is

*** Settings ***
Library RequestsLibrary
Library Collections

*** Variables ***
#Run the script
#robot -d results .\APIs\TC1_GET_Request.robot

*** Test Cases ***
Create Session mysession ${base_url} disable_warnings=1
${body}= Create Dictionary name=ajaybodake job=SSE
${header}= Create Dictionary Content-Type=application/json
${response}= POST On Session mysession /api/users data=${body} headers=${header}
… verify=False

Log To Console    ${response.status_code}
Log To Console    ${response.content}

 ${status_code}=    Convert To String      ${response.status_code}
 Should Be Equal    ${status_code}    201
${res_body}=    Convert To String    ${response.content}
Should Contain    ${res_body}    SSE

This message is not related with the initial topic. You should have created a new one, not related with RIDE.

You need to add an “insecure” option to RequestsLibrary, look for the documentation.