Request For Comments - New lines in Grid Editor

We need your opinion about the change request at PR 2249.

With this change it is possible to insert newlines in cell content, and see it nicely on Grid Editor in navigation mode.
For example:

But when editing the cells, we don’t see the \n and if adding newlines with \n or Alt-Enter, they will be translated to real newlines in both Navigation mode and Edit mode, see:

When we see in Text Editor, the \n are there like they should:

  1. Would this behavior fine as it is (\n translated to real newlines in Grid Editor)?
  2. Should this behavior be changed to keep \n visible when editing in Grid Editor?

Created a Poll at Slack #ride channel.

This the current look of cell edit in Grid Editor (2.0b1):

Looks ugly, but this is what I propose to keep ;).

it seems button text is always white and difficult to see for robotframework-ride any version on macOS

I could not reproduce your problem. Tried with both dark and light themes.

Tried with RIDE 2.0b1 in Python 3.7 with both wxPython 4.0.7.post2 and 4.1.0.

MacOS with latest update.

@nixuewei Maybe you should post what are the versions you used.

@HelioGuilherme66, please forget this issue. it so strange i have use white button more than 1 years on macos. but today when i open ride. it became normal. It is amazing. i seems like does not do any action. i check my version is robotframework==3.2.1;robotframework-ride==2.0b1;wxPython=4.0.7.post2. macos catalina 10.15.5. python 3.7.7 anyway, it good for me now. thank you for you effort. you are great!

1 Like