Getting random connection error with Zoomba desktop library


I am getting this error at random places in my testsuite while running it using zoomba desktop library

[ WARN ] Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x00000281EAEEECD0>: Failed to establish a new connection: [WinError 10061] No connection could be made because the target machine actively refused it’)’: /session/325FAECF-3ACE-4FEC-A4EA-A33C562FA2CB|

I tried to change the win-app remote URL from default to something else but it seems that connection fails from start when it is change

not sure what could cause these issue as one test work fine then i get this issue all of a sudden.

any help would be appreciated

After further investigation, this error shows up when using the “Capture page screenshot” keyword, if I don’t take screenshot the test goes on its merry way…

not sure what causes this issue

No sorry worked with screenshot it is random :frowning:

I think my question is the following.

how do I get zoomba library to use a different port?

  1. Answering a bit blind here as you haven’t given any sample code or logs.

  2. Sounds like WinAppDriver is crashing on your for one reason or another, are you sure you installed it correctly and enabled the settings required?

  3. In terms of setting a new port, using the Driver Setup keyword will launch the driver with the default port. If you want to change the port you can launch the WinAppDriver manually to see if that would help and we could maybe add that feature in the future.