Save button not activated after the input of a value

Hell to all, I face a strange issue. I have a web page where when I enter a value in a field, it automatically enable the Save button. When entering the value with Robot, the Save is never enabled, so nothing is neveer saved and that make all the subsequent tests to failed

I tried to force a Return :
Press Keys ${Txt_BloodGlucoseValue} RETURN

I tried to have more sleep time, the Save is never enable. It looks like the value is there but never taken into consideration.

Note that the field “Value” is a inputmode=“decimal”. It may be related ? However I have other fields with the same inputmode and I don’t have any issue with it.

Any idea would be much appreciated!

Could you trying sending the tab key instead of return

Thank you for your answer. I tried and it does not change anything.

That’s a shame, I had a similar case a very long time ago with a different framework where the label wouldn’t adjust to an input field that took numeric values, and sending of keys tab or clicking away after input would adjust that label… but the input mode wasn’t “inputmode=“decimal”

Oh, SeleniumLibrary or BrowserLibrary? always helpful knowing which you are using (both selenium and browser library have the same name keyword for press keys, so it’s not that obvious for which you are using)

So having a quick look (I’m sure there is if this is the case then there be other examples) that the input mode may be the cause, something I just fell on (maybe an unpopular suggestion if it works) but for a numeric mode, given yours is decimal is to try:

  • Input value as normal
  • highlight all in the box
  • cut
  • paste back into the field

I do have to dash though sorry, hopefully, others could help if the above doesn’t help


Thank you Daryl! I tried all of those and unfortunatly it did not worked. I will continue to look for a solution :slight_smile: don’t hesitate if you have other ideas!

No problem :slight_smile:
→ Be worth understanding what library you are using: SeleniumLibrary or BrowserLibrary (you may have missed the question above …more so as both libraries hold the same keyword Press Keys so little hard to know which you may be using)
→ Is the site public-facing, for us to take a look at?
→ What value are you trying to pass to the field and how (sharing that part of the tests would be useful) as you mention the field is of type inputmode=decimal.

You mention:
“Note that the field “Value” is a inputmode=“decimal”. It may be related ? However I have other fields with the same inputmode and I don’t have any issue with it.”

Does the save button require a set of fields to have value before the save button becomes active to proceed, or just this one field?

Hello again

  • I’m using Selenium library
  • I’m trying to enter a blood glucose value, so pretty simple value : 7
  • No the site is not public, unfortunatly I cannot give you access
  • The save button is enable once user has entered a value in the Blood glucose value field, so just this one field. If we do it manually, it work. It is when the value is entered by Robot that this button is never enabled

here is a screen shot of the input field

Why not Click Element, then Input Text?

I do “Click Element” before “Input text”

Thanks for the details, Helios reply is definitely an solid suggestion to try

You might find set focus useful for after the input to a different element:

Also, what browser are you using and version with selenium library as the inputmode attribute does only support certain browsers versions, not entirely sure if that would influence it [edit] just wondering if the versions differ from when manually doing it.

The interesting thing is that I have the a page with the exact same kind of element where save button is enable after user has entered a value and it works 100% … really strange

I did tried the Focus Element, it is not working either. Another interesting thing, when robot test is running, I manually enter a value in the problematic field and it does not change anything, the save button still disable

i’m using chrome Version 109 and upgrade selenium library as well

Just an idea, and I know you mention when done manually it works and that you have another page that works similar to this with a field with that attribute.

but with the steps leading up to that point of failure here (unable to click button as it’s disabled), so if you was to replicate the steps manually (not sure if this is what you have tried when you mentioned manually) so like for like in terms of the journey, clicks and data inputted as per the test which keeps failing, could a step prior be a cause of a bug with the UI here that you’ve stumbled on?

It’s also worth taking a look at the console window during running in the browser to see if any errors are being returned, as you may find there could be at that point.

[EDIT] two early questions, I was interested in asking but totally forgot.

Q1: Can you increment the numbers in this field via the UI or by UP|DOWN keys? Is so it might be worth trying this as means to debug, so after input possibly sending those key presses to see what happens with the button (really shouldn’t be needed though but more of an interests) but just for the sake of debugging it might prove useful?

Q2: You mentioned on another page that you have a similar/if not same field and it works, and you mentioned you’re inputting 7 here… what value do you input on the other page that works? Is it a whole number or a point of a decimal? You could try here with the one which is being problematic with changing the value to a point decimal to see if this the cause? 7.0 or 7.1 or to the same value which you pass on the other page?


Hi Daryl. Turns out that the problem is now fixed an it was related to a previous field (00 in minutes was causing the issue and its a bug). Probably my eyes were in it from too close and too much time so I was not seeing it! You pointed it in previous response that it is maybe related to a set of fields not only that one, you were right :(. Anyway, I have learned lots of other ways to validate when I have errors, and I thank you for that ! I am also really impressed of how you put effort to help!

Thank you for all the help!


Oh that’s great news! and not a problem :slight_smile: was a fun one, I’m glad youve picked up a few things to.

1 Like