Sapguilibrary linux ubuntu

i am trying to install sapguilibrary on ubuntu 22 getting this error

Requirement already satisfied: robotframework>=2.9 in /usr/local/lib/python3.10/dist-packages/robotframework-6.0.1-py3.10.egg (from robotframework-sapguilibrary==1.0.3) (6.0.1)
ERROR: Could not find a version that satisfies the requirement pywin32>=222 (from robotframework-sapguilibrary) (from versions: none)
ERROR: No matching distribution found for pywin32>=222

is there a way to install pywin32 on linux ?

No there is not.

Either the library is for Windows only, or the requirements is badly written.

Hi Jose,

SAP GUI Family

That sapguilibrary is probably for the Windows version of SAP GUI.

If you are using Linux, does that mean you are planning to use:

  • the SAP GUI for Java? if so you probably want to look into one of the java libraries for robot framework.
  • the SAP GUI for HTML? both SeleniumLibrary and BrowserLibrary can drive this version.

Hope that helps,