Robot Test Getting stuck on Run Process keyword

Hello everyone,

I have been facing this weird behavior with one of my testing machines where one test get dead stuck on the following keyword
It was running normally last week, but now for some reason it gets dead stuck and even ctrl+c cannot abort the test thus the cmd must be completely closed, so I’m not even getting any logs back.

I tried to test this single keyword alone , and I tried to run it using the shell and without but still gets stuck and the test ran normally when I commented it out so I’m sure it is the problem, I also tried to add a timeout for the test, but still it won’t abort.

although the keyword Run Process itself is running normally in every other part of the test, and the test work normally on all of the other machines.

This is the current version of Robot framework

I have changed the “Run Process” keyword by the “Run” keyword from the Operating System and it works fine, but I just don’t understand why it behaves like this, any ideas?