Robot Framework Zoomba Multiple Keywords with same name was found

I installed Robot Framework Zoomba 4.0.0 (fresh pc fresh install nothing installed before) and opened a project that used normal Robot Framework beofore i got this error ex: Multiple Keywords with name “Open Browser” was found. I replaced Library SeleniumLibrary with Zoomba.GUILibrary and didn’t changed nothing, then restarted VS code and it worked but after some minutes without touching anything i got the same error again then restarted VS and same story again. Anyone have an idea on how to permanently fix this issue please?
Thank you,

Even with:
Suite Setup Set Library Search Order Zoomba.GUILibrary

I get the error:


You can’t have the same keywords called with same name, even if they are part of different libraries.
The 2 solutions I see would be :

  • Add library name before the keyword use/call i.e. Zoomba. GuiLibrary.Keyword
  • Verify there’s no import to the Seleniumlibrary in your test or related suite/dependencies
  • Or uninstall Seleniumlibrary if not using it




Yes that’s why i replaced Library SeleniumLibrary with Zoomba.GUILibrary in all my files.
I think it’s a Robotcode extention issue because suggest fix by VS was to add robotcode: ignore:
[Teardown] Run Keyword And Ignore Error Close All Browsers # robotcode: ignore

It fixed the issue but i will have to do that everywhere and it will be a lot, I don’t understand why i’m still getting this issue even without having any import of SeleniumLibrary in any of my test files.

I can’t uninstall SeleniumLibrary because there is an import of it in Zoomba.GUILibrary


Hey @SAproX1, I had a colleague that was running into the same issue with another extension in VSCode. It seemed his solution was by switching to “RobotCode - Robot Framework Support” as his extension and that fixed it from him. If you are already using that extension then I would be sure you don’t have any other robot extensions installed.

And to be clear, while you will get the annoying red underlining, code does execute just fine right?


If the above solution does not work, and no other solution or bug is found, I would rather use the full library name in keyword use.

You could use an alias in import line to reduce the name. Then for existing files do a search and replace of all the used keyword with regex maybe (and use a python file to get all used keyword from the library first).

Adding robotcode : ignore will indeed be a lot of job, and might mask some other issues when refactoring code sometimes.


Hello @Wolfe1
Yes I’m already using the same extension without any other one… weird as i never faced this issue last time i worked with Zoomba 2 years ago.
It stays red and can’t bypass this error as it stop the test from going any further.
Any basic keyword shared with Zoomba and Selenium (Open Browser, Maximize… Set Speed…) will endup red… it forces me now to uninstall Zoomba…
Otherwise which version of Zoomba/Selenium are you using without issue please?


Hi Again,

Might be something in the installation.
I’m using VS Code, RobotCode v0.79.0, and installed last ZoombaGuiLibrary and have no issues :


Versions are this ones, pip uninstalled my last 6.3.0 version of SeleniumLibrary :

Selenium version is the 4.18.1
Do you have same versions ?


Hello @CharlieScene @Wolfe1
I think it was the fact as some Resources in the Settings contained some SeleniumLibrary Imports, now that i deleted these resources it seems to work fine.
*** Settings ***
Resource %{TEST_KEYWORDS_PATH}/BO/file.robot

If this file.robot contains an import of Selenium and you have Zoomba installed it will generate this multiple keywords issue.
Hope it’s just that and it will be fine , hope this will help others as well especially when you work on an already existing project dev with basic Robot Framework and you want to include Zoomba library on it.

Thank you very much guys.