Rfswarm for performance test : Someone has already use it?

Hello,

I found “rfswarm” which is a testing tool that allows you use Robot Framework test cases for performance.
I’m not a dev and I have many difficulties to configure it to run it on my machine.

Someone has aleready use it and can help me?

Thanks

I am doing a PoC to maybe adopt it in my current project

Perhaps can you help me to configure it ?
I would like to run tests with GUI and Agent on the same machine and I don’t succeed to connect the 2 elements

Well you have to start the rfswarm server and then the agent. By default, the agent will point to localhost.

I have done this but the agent try to connect to localhost (I have run rfswarm-agent on debug mode to see this…) :

Try connecting to http://localhost:8138/.
I try to change “localhost” by its IP (127.0.0.1) but it doesn’t work anymore…

In the folder where rfswrm is installed there is a file called RFSwarmGUI.ini

There you’ll find the configurartion of ip and port for rfswarm.

Here is my actual configuration. Is there something wrong ?

On the RFSwarmGUI.ini

  • bindip = 127.0.0.1
  • bindport = 8138

On the RFSwarmAgent.ini

The configuration is matching. It should be working.

Unfortunatly, it doesn’t work…
On the GUI console, the message “Not enough Agents available to run Robots!” is appeared.
On the Agent console, the message “Try connecting to http://localhost:8138/
But I don’t know how to add agent.

If you can help me, it would be super !

Not that this solves anything, but curious why you use IP 127.0.0.1? That’s the same as localhost, unless that’s the intent. I would have thought that you would at least put in the host’s real network IP.

So you think that on the Agent console, i keep this config (with localhost address) and on the host, I put my real network IP?
This way is different than @Paulonsalarcon has said, but both works?

@Centaure13 Hi John,

Are you still having trouble connecting the GUI and Agent?

I see you had configured:
On the RFSwarmGUI.ini

  • bindip = 127.0.0.1
  • bindport = 8138

On the RFSwarmAgent.ini

  • swarmserver = http:/ /127.0.0.1:8138/

I suggest you start with changing the RFSwarmGUI.ini to:

  • bindip =
  • bindport = 8138

As the bindip setting is only needed when you have multiple ip addresses on the machine you are running the GUI on and you want to limit it to only 1 of them, not setting it to anything it will respond to connections that come in on port 8138 from any interface which will make things easier for you.

next for the RFSwarmAgent.ini, on most computers these 2 lines do exactly the same thing unless your localhost entry in your hosts file is misconfigured.

  • swarmserver = http:/ /127.0.0.1:8138/
  • swarmserver = http:/ /localhost:8138/

You said you were trying to run them both on the same machine so this should be fine.

Next launch both the agent and the GUI (it doesn’t matter which one you start first, any order is fine) and have the both running, in the GUI go to the agents tab and wait a few minutes, the agent should poll for the GUI/Server every 10 seconds, but the agents screen only refreshes every 5 seconds so it can take ~15 seconds for the agent to be visible.

If after 1-2 minutes the agent is not showing up there might be something like a firewall blocking it, so you might need to adjust your firewall settings, but without knowing which OS you are using I can’t tell you where that might be, try googling " firewall" to find your firewall settings. I would suggest you disable the firewall for a few minutes to determine if that is the issue, if the agent connects to the GUI then turn the firewall back on and start researching how to configure it for allowing a connection to port 8138.

I hope this helps, and I’ll check back here over the next few days to see if you have any questions.

Dave.

1 Like

@Centaure13 Hi John,

I have been checking back here every few days, but there have been no further questions so I hope my answer helped you, feel free to post again if you need further help.

Dave.

Hi Dave,

Sorry for my absence, but I just became a dad so I have been very busy :slight_smile:
I’ll look at your solution and get back to it in this post!
Thanks again !

Congrats on the baby, hope mum and baby are healthy and well, Dave.