Pycharm Plugin issue

Hi Team,

Currently I am using browser library for the robot framework and pycharm as IDE.But the issue is every now and then the plugins are not working properly. I have tried all type of robot framework plugins present in marketplace of pycharm but still the issue is present. Issue is “Pycharm is automatically disabling the plugins which are not tagged to jetbrains”. As a result of which the keywords are not recognizable.I tried to use visual studio code but their also i am facing same issues . I am not sure if this is IDE issue or the robot framework plugins compatibility issues.Only solution is to restart pycharm again and again which is kind of irritating to do in between work.

Any other solution for this issue will be helpful.


VS code with Robot Framework Language Server extension works well. Facing the same issue lately with PyCharm recently. No solution for Pycharm yet but VS Code works fine.

Remove all extension related to robot framework in VS Code and install only Robot Framework Language Server - Visual Studio Marketplace

Restart VS Code and check once, should work fine.