Using PyCharm for Robot Framework - Issues Faced

Hi All,

We are trying to use Robot Framework with PyCharm and I am facing few issues while trying to proceed.

I am using:
Python - 3.6.7
Robot Framework - 3.2.1
PyCharm - 2019.2

Tried to create a Project with Robot Framework in PyCharm. Found that I need to install “Intellibot” plugin in PyCharm which is help us use the Robot Framework features. Later in another video, found that I must also be using another plugin called “Robot Framework Support”. I am really not sure what all plugins must be used for having the Robot Framework features in PyCharm.

It will be really helpful if someone could share links/ documents for the user guide (Using Robot Framework with PyCharm).

And also, when I try to use Selenium Library in my Test Suite, it is not showing the keyword list in dropdown when I use Ctrl + Space. As mentioned earlier, I am using “Intellibot” and “Robt Framework Support” plugin.

Thanks,
Apoorva A

Hi Aproova,
I just recently needed to set up new project:

  • Few useful hints:
    1. IntelliBot is quite unmaintained try using IntelliBot @SeleniumLibrary Pathced - This one works best for me also with BDD Gherkin style
    2. Also try this plugin to see if it suits you better : Robot Framework support
    3. Configure interpreter: Create new venv from pycharm settings/interpreter, pip install all needed libraries
    4. Configure project structure Settings/Project / Project Structure and set Resources to where your libraries / keyword files are.

Just to be sure, invalidate caches and restart pycharm.

Let me know how it worked :).

J.

Apoorva,
I also faced the similar issue and able to resolve by following steps

  • Install Pycharm version 2017.3.3
  • Download intellibot plug in from : https://github.com/lte2000/intellibot
  • Open your pycharm and go to settings -> Plugins -> Install Plug in from disk. Browse downloaded plugin
  • Click on OK
  • Restart Pycharm
  • Now, again go to settings -> Plugins -> Search for Intellibot @SeleniumLibrary Patched and Install it

This should solve your problem

I would recommend using VS Code instead with the following plugin:

https://marketplace.visualstudio.com/items?itemName=TomiTurtiainen.rf-intellisense

I have found this much superior than PyCharm.

Hi,

Would you please explain step 4 for me please? By default Pycharm set my source folder to the location of my robot project like C:\robotframework\webplustest. It is my project folder from ‘C’ drive.

Where does the libraries/keyword files are?

Thank you for your help.

Hello,

I installed the Intellibot @SeleniumLibrary Patched and still get problem. I am not able to make the seleniumlibrary to come up when I type like Open Browser. I also have error from the event log for this plugin.

Please help

Hi @judyluong ,

I don’t understand: what do you try to achieve? The source folder looks fine for me.

What about libraries and keyword files? I’d guess they are in some of these subfolders. CustomLibs and Resources maybe.

Unless you mean by “libraries” external libraries like SeleniumLibrary, those would go to in to venv, but you never have to check there.

Be aware, that PyCharm is no Robot Framework IDE. You need to look at the project from a python perspective. You can set up a python environment and install robotframework dependencies in it. Robot Framework plugins help a little bit with auto completion.

Using a venv is good practice! Now, if you open a terminal in PyCharm you can install dependencies with pip:
(venv) C:\RobotFramework\WebPlustTest> pip install robotframework-seleniumlibrary

You also need to run robot from this terminal command line (or create a Run config):
(venv) C:\RobotFramework\WebPlustTest> robot Tests/*.robot

Regards,
Markus

Thank you for your help. I will try it and let you know.