Need Help with our XML file that is generated

Hi to all Robotframework users and Gurus.

we are seeking your advice, currently using robotframework-3.0.2.jar with java 1.8.0_181

we are running out automation script using this line
java -Xms514m -Xmx514m -cp “%csp_lib%*;%common_lib%*” org.robotframework.RobotFramework --include DEMO --outputdir …\Test_Driver\Reports\DEMO_DEMO_%SUBFILENAME% --variablefile …\Test_Driver\Server_Settings\ …\Test_Case_For_Testing

This is the content of our java library

we are currently encountering an error wherein jemmy is not being triggered, upon upgrading our application and is causing issue with our output.xml file which in turn causes problem to the generation of the html file (the XML file is cut at the end)

we tried using robotfixml and rebot but it does nothing.

your knowledge and input is greatly appreciated.



i have never seen this, but could you upgrade robotframework to 3.2.2?

The 3.0.2 you are using is a 3 years old version. (released Feb 2017)

Thank you sir Rene, we will upgrading to 3.2.2 and execute our test again.

we will get back to you asap.

Hi sir Rene,

we have upgraded to latest robotframework version, but still get the same result.

Your guidance is greatly appreciated.


Are you sure you are doing it right?

you wrote in you first message, that you are using robotframework-3.0.2.jar.
But with pip you get robotframework python…

i am not a pro with jython, but afaik you have to exchange you jar file with the one i posted.

Hi Sir Rene,

We used pip install to ensure that we are using the latest Robotframework, installation was through jython, I also have a copy of the Robotframework-3.2.2.jar and have place it on our javalib folder which is being referenced by out execution bat file.

Thank you for your guidance.