My test case suddenly stop without any notify

I tried to use Pybot to execute a test suite, but when I looked at the command line, there was no response indicating whether the tests passed or failed. The execution stopped immediately at a random test case in my suite when I tried to run it multiple times, so I assume that there is no problem with my test cases.
Can you please help me with this issue? Thank you in advance.

Pybot is very ancient name for robot.
Please paste here the output of:
robot --version

If you are really using pybot version circa 2.9, then I doubt someone will help you (with so little info you provided).


Sorry for the mistake, i meant robot actually, here is my cmd after robot [my test suite] command

As you can see in test case 58, there is no response and it suddenly terminates. I have tried many times, but the result is that the test case stops randomly.
My robot version is 6.1

Some things to improve your reporting here at the Forum:

  • Try to avoid using images, prefer to copy and paste simple text (preferably, using code formatting)
  • Mention what is the most important or relevant Library and its version.
    (This may improve user’s response to help you!)

The error mentions CAN, so it may have to automobile industry. Do you use any specific Library for this? For example is your connection, with a Serial link?

Your problem is very specific for the type of connection you have. The failure could be from your Software Under Testing (SUT), or from the Library.
If from the Library, you may have some options to increase the timeout before failing.

This is all I can say to help you.
Good luck.