Location of Chrome WebDriver

Hi all,

I am struggling with the following problem. I wrote a Robot test and let it run in Jenkins. There it throws although the following error message: SessionNotCreatedException: Message: session not created: This version of ChromeDriver only supports Chrome version 97 For me it sounds like Robot does find the Chrome WebDriver, but it has the incorrect version.

Here is my problem. I cannot find the Chrome WebDriver to update it. I tried to search for it in explorer, looked up in environmental variables (nothing).

Does somebody maybe know where or how does Robot look up for the Chrome WebDriver? In what locations does it check for it?

Thanks a lot in advance.


Welcome Mischa to the Robot Framework forums!

It sounds like when you say you are “running it on Jenkins” that this is a separate machine? That error message This version of ChromeDriver only supports Chrome version 97 is saying there is a mismatch between the Chrome version and the ChromeDriver version. If this is a remote machine with limited access (although one should still be able to ssh into it) you could have some steps in the Jenkins build to output both the chrome version and the chromedriver version. I believe the following will work

google-chrome --version
chromedriver --version

Then you should be able to check the correct chromedriver version for the version of chrome that machine has at ChromeDriver - WebDriver for Chrome - Downloads

Hello EdManlove,

Thanks for your response! You are right, there is a mismatch between Chrome and WebDriver versions (WebDriver supports Chrome up to version 97, but the actual version of Chrome is 100). And yes, it is a separate machine, but I have admin rights there.

So as I see it, there are two solutions: either update the WebDriver or install an older version of Chrome. From my point of view the first solution is better, but there I have the problem stated above that I do not know, where does Robot look up for WebDriver and I could not find it in explorer.

I also tried just to download and placed the correct version of WebDriver in some folder and to mention it in the environmental variables, but the error stayed in place.

So do you maybe have an idea how to find the WebDriver?


If it is a Linux/Unix based machine (i.e. not Windows) then which chromedriver would tell you where it is. If it is windows machine the executable would need to be on the path so using echo %PATH% at either a command line or by adding that into the Jenkins steps would hopefully highlight it for you. (Sometimes people put the executable into another folder that is already in the path as compared to what I do and recommend which is to put it into a well name path/folder like “/development/selenium”)

That you don’t have admin access, part of the solution I would think would be to work with them to properly configuring the system. They might have some understanding as well.

Thanks a lot EdManlove, it was basically the solution. Before I also tried to check every single environmental variable, but did not find anything like “chromedriver.exe”.

I am on the Windows machine, so I added “echo %PATH%” to the section “Build - Execute Windows batch command”. It shows a lot of paths, beside others the path to the Chrome WebDriver (it was in a protected folder, therefore I was unable to find it with the Windows Search - it was in “C:\Windows\System32\config\systemprofile\AppData\Local\Jenkins.jenkins\tools\chromedriver”).