ChromeDriver : It doesn't work anymore

Hi,

Yesterday, my tests worked fine but today, impossible to launch my tests with Chrome.
Here is the error message :

FAIL : SessionNotCreatedException: Message: session not created
from tab crashed
(Session info: chrome=90.0.4430.212)

It’s seems to be different than the error message who says “This wersion of ChromeDriver only support Chrome version xx” because I have only the message above.

I tried to update my Chromedriver with the latest version ( 90.0.4430.24) but the result is the same.
Nothing has changed by my side between yesterday and today…

Have you an idea ?

Thanks a lot

Hi John,

Open Chrome and check the version, it’s quite likely that Chrome updated it’s self while your tests were running yesterday

Chrome 91: May 25, 2021
https://support.google.com/chrome/a/answer/7679408?hl=en

You will probably need to update your chrome driver.

Dave.

Hi Dave,
My Chrome Browser is always on 90.0.4430.212 version.
I tried to update my chromedriver (by downloading the latest version - 90.0.4430.24 and replace it on my “Script” folder), reboot my Eclipse but I have always the issue…

For information, my library “webdrivermanager” has the version 0.10.0 (but it’s the latest)…

I begin to see the exit lol…
I have download the latest version of Chrome and now I have the error message “This version of ChromeDriver only supports Chrome version 89”.
I have downloaded the latest version of ChromeDriver.
But it doesn’t work… I check again again where I failed…

I have a strange behavior…

  • I put the latest version of Chromedriver on “Python38-32\Scripts” folder… I have the FAIL message without the message concerning the Chromedriver version
  • I keep this version here, and I put my former version on “Python38-32” folder, I have the FAIL message WITH the advert concerning the version
  • I replace my former version with the latest version… I only have the FAIL message without the version message…

I’m lost…

Hi John,

Are you downloading the chrome driver manually?

I use webdrivermanager to update the drivers for chrome, firefox etc, as I find it much easier

e.g. for me on a new computer to run selenium library I just run:

$ pip install webdrivermanager
$ webdrivermanager chrome

then if chrome updated I just run (again):

$ webdrivermanager chrome

This is also one of the reason people use Browser Library, the playwright components behind Browser Library uses Chromium so they can control the versions it manages the drivers and browsers for you, so that might be a better option for you, depends if you need to use Chrome for your testing or if Chromium is ok, also depends if it’s critical to you that your tests are run on the latest Chrome engine or not?

Dave.

Hello,

It seems to be OK now…
A simple reboot of my computer (and the download of the lastest version of chromedriver) has resolved the issue.

However, I keep your explanation because I guess it could be useful … :wink:

Thanks again