Http Credentials seems to keep giving Warn

Hi ,

it seems I keep getting an error using http credentials with new Context , to use with SSO sign on ,

saying that it no longer supports the format of ${var} and to use $var

But i have tried multiple combinations and none of them seem to work

variables

${user}. abc
${pass}. xyz
&{credentials}=. ‘user’= $user. ‘password’= $pass

new Context. httpCredentials= &{credentials}

Could some one please assist , how to make it such that the credentials are not showing up in Log and also no warnings are showing up , any assistance is highly appreciated

Please state what version of Browser you’re using.
what worked for me was:

httpCredentials={‘username’: ‘$credentials.username’, ‘password’: ‘$credentials.password’}

1 Like

Am using 3.2.2

@leeuwe : Am still getting warn , and the credentials are visible on the log , am looking to hide that and disable the warnings , can some one guide me on how to do this or the

latest syntax of using httpcredentials ??