Unable to redirect output

Hi folks,

I’m just starting with RF and I successfully integrated it with VSCode. The initial test passed OK, but I’m experiencing an issue, with redirecting output to custom “Reports” folder. I found some tips about adding “args” section to “launch.json” file. Unfortunately, this did not help.

Here you can se my launch.json and also the bat file, where is definitely missing outputdir argument. Am I missing something?..

Which extensions are you using? It seems that you have installed “RobotCode” and “Robot Framework Language Server” together? You only need one of them, I would recommend you to use only the RobotCode extension.

With the RobotCode extension, you do not need to specify any launch configurations to change the output path for your test executions; it is set to the results folder by default. If you want to change it, just change robotcode.robot.outputDir in the vscode settings or, brand new, create a robot.toml file in your project directory, look here for a tutorial:

full for robot.toml documentation is coming soon.

Hi Daniel, thank you for the reply. Uninstallation of “Robot Framework Language Server” helped. I was under the impression that I need both extensions :smile: