RF or Chrome for Testing inserting string into URL "%C2%AO"

Hi all,

Some of my tests are failing because either RF or Chrome for Testing is mangling the URL. Specifically it is inserting “%C2%AO” after the ${BASE_URL} before any suffix. This is a new issue for us in the last week. When I trace the URL formation variables, they are clean. The URLs in the log are also clean (though they still fail with a 404). I can only see this when I run the test with the browser observable, so I can see it going to the malformed browser. An example URL is something like https://mysite.com/�%AO/someotherpage

Has anyone seen this or has ideas for troubleshooting? I’m stumped.

Hi Andy,

I’ve not seen anything like this with any of the common libraries.

  • which library are you using?
  • can you make a simple test case that we can use to reproduce the issue with a publicly available site?
  • which version of robot framework are you using?
  • what are the versions of your libraries?

FYI the utf-8 charecters for those url codes are

  • %A0 is Non-breaking space
  • %C2 is Â

But without more information I can’t help more than that.


Hi Dave, thanks for the reply.

I’m using the Selenium on RF 6.0. I’m running from within a venv and as of last week using Chrome for Testing (which was its own journey getting functional). I’ll try to find a public example. I figured those were character codes of some sort - right now I’m experimenting with some escaping to see if I can circumvent the problem.


Hi Andy,

A couple of suggestions:

  • Check your SeleniumLibrary version and your Selenium version as there recently have been issues with changes in Selenium 4.10 with all but the most current SeleniumLibrary version, I don’t think this is your issue but to be better safe
  • If you can open your robot file with a text editor that allows you to enable a setting to show all characters (aka invisible characters) to makes sure you don’t have those somehow accedently added to your script

I don’t think it’s an escaping issue, sounds more like those characters are getting added in somehow, just a matter of troubleshooting to figure out where.


Hi Andy

I’m facing thenRobot Framework & Chrome for Test issue now,

Would you mind providing your solution?

Hi Orrin - I think this was an issue in the command I was providing relating to the base URL. I had to play with it for a while to get it to go away but my suspicion is that a change from Python 2 to Python 3 on our end made it less tolerant of something or that extra noise was getting in from copying and pasting.

1 Like