Location KeePass file not found (Azure)

Hi All,
I am busy to create an build pipeline in Azure DevOps.

One of the install dependencies is: “robotframework-keepasslibrary”
The file is stored in the robot script: image

When i running the pipeline i get an FileNoteError: FileNotFoundError: [Errno 2] No such file or directory: ‘./…/…/…/…/…/pass/Database.kdbx’
On my local machine its works fine and the Database with the kdbx can be open.

anyone have an idea

You are using relative path that is dependent on execution directory. You could check it by adding somewhere Log ${EXECDIR} and comparing it.


You need the identity file to login to the box. Use the command:

ssh -i (identity_file) username@hostname"

This worked for me. Write just the filename (without any slashes), unlike Amazon EC2 tutorial which asks you to enter:

ssh -i /path/key_pair.pem ec2-user@public_dns_name

It worked for me after putting the identity file in the .ssh (hidden) folder on home. To view hidden folders on home, use ctrl+h