GLIBC_2.18 not found

Running robotframework-browser 3.3.2 on RedHat 7.9 we always get errors like this:

[err] /opt/jenkins/python/lib/python3.8/site-packages/Browser/wrapper/node_modules/playwright/node_modules/playwright-core/.local-browsers/firefox-1297/firefox/firefox: /lib64/ version `GLIBC_2.18’ not found (required by /opt/jenkins/python/lib/python3.8/site-packages/Browser/wrapper/node_modules/playwright/node_modules/playwright-core/.local-browsers/firefox-1297/firefox/

E.g. here it’s described a simple GLIBC update is not possible: Upgrading glibc within a current release in Red Hat Enterprise Linux (or CentOS) is not possible.

If I run the browser directly /.local-browsers/firefox-1297/firefox -headless it works without errors.

So I guess Playwright needs the GLIBC 2.18? Probably not the rfbrowser lib? Does somebody had the same error and even knows a solution?

Maybe it’s possible to downgrade the playwright version?

Btw Python is 3.8.7 and Robot is 3.2.2.

Thanks, Rainer

In case somebody else has this problem: There is no fix for RedHat 7.x. We did upgrade to RedHat 8.x to have the needed GLIBC version.