Error with the Keyword "New Browser"


I wonder what’s wrong on my environment now. I guess I broke something because it worked recently After an installation command on pip for another thing, my RF script is no more cooperative.

My OS is Windows 10.

I have an error when I use
New Browser chromium, headless=False, args=['--incognito','--auth-server-whitelist="_"','--ignore-certificate-errors']

The error is :
‘str’ object has no attribute ‘name’

If more informations are needed tell me what you want to know (I dunno what could help about it).

Thank you for your attention.

Just a precision a simpliest call of “New Browser”
New Browser browser=chromium

get the same error.

Interesting, would you be able to run test with --loglevel trace set from command line and show us the full stack trace?

The trace is :…
Traceback (most recent call last):
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\Browser\”, line 149, in grpc_channel
yield playwright_pb2_grpc.PlaywrightStub(self._channel)
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\Browser\keywords\”, line 390, in new_browser
Request().Browser(, rawOptions=options)
AttributeError: ‘str’ object has no attribute ‘name’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\Browser\”, line 956, in run_keyword
raise e
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\Browser\”, line 946, in run_keyword
return DynamicCore.run_keyword(self, name, args, kwargs)
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\”, line 102, in run_keyword
return self.keywords[name](*args, **(kwargs or {}))
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\Browser\keywords\”, line 393, in new_browser
return response.body
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\”, line 131, in exit
self.gen.throw(type, value, traceback)
File “C:\users\rickcanard.pyenv\pyenv-win\versions\3.8.0\lib\site-packages\Browser\”, line 156, in grpc_channel
raise AssertionError(str(error))
AssertionError: ‘str’ object has no attribute ‘name’

The Open Browser keyword opens a new browser , a new context and a new page. This keyword is useful for quick experim space bar clicker The Open Browser keyword opens a new browser , a new context and a new page. This keyword* is useful for quick experiments or debugging …ents or debugging … Trying to automate this application in Katalon. Whenever the automation script is run for login to applic… Katalon Studio automatically prompts a new …

Hi @Noradavis,

Your message does not make any sense in the context of this topic?

Are you trying to ask a question? if so please create a new topic.

Are you trying to answer @Stephane’s question? It seems all you’ve done is paste the content of the help which is clearly not relevant to this problem.

FYI Katalon Studio is not supported by the Robot framework community, if you are looking for help with Katalon Studio I suggest you try their forums, which based on my past experience are quite good and very friendly.


I found a solution and a potential explanation about my problem. I just saw that an other version of Python on my pyenv works. I guess I broke severely a dependance on the initial Python environment I used. An accidental installation back to 4.xx Robot Framework is the suspect (I upgrade to 5.0 just after but it was too late). Then if I reinstall completely Python and the libraries I need it works again. My bad … as usual :confused:

1 Like