Error with Chrome version 88

I am getting error from Chrome 88 and not able to bring up any webpage. I am using version 88 for the Chrome WebDriver and still getting the error. Which version of Chrome should I be using is a good version? I am using Robot Framework seleniumlibrary 4.5.0, Robot framework 3.2.2, Selenium 3.141.0.

[20088:16400:0122/153444.048:ERROR:device_event_log_impl.cc(211)] [15:34:44.053] USB: usb_device_handle_win.cc:1049 Failed to read descriptor from node connection: A device attached to the system is not functioning. (0x1F)

Thank you for your help

2 Likes

I also get USB: usb_device_handle_win.cc:1049 Failed to read descriptor from node connection: A device attached to the system is not functioning. (0x1F)

I have this error too and I didn’t solve using these solutions or removing USB devices attached

Hi guys, it might be worth mentioning what platform you are experiencing this on?

As an FYI I was playing around with Chrome 88 on a docker image based on Ubuntu 20.04 yesterday, I was not getting this issue.

If you can confirm that this only happens on one os (windows?) then that might help in finding a solution.

Sorry I can’t be more help than that,

Dave.

@damies13 For my case, I am having this issue with a Windows10 home OS and a Google Chrome Version of 88.

The issue is as follow:

I found some discussions on Stackoverflow but still cannot solve this problem. Here are some discussions from StackOverflow:

  1. python - Failed to read descriptor from node connection: A device attached to the system is not functioning error using ChromeDriver Selenium on Windows OS - Stack Overflow
  2. python - USB: usb_device_handle_win.cc:1020 Failed to read descriptor from node connection error with ChromeDriver v87 / Chrome v87 using Selenium on Windows10 - Stack Overflow

Hi,

And I was getting an error message similar to this one and I managed to solve the problem by placing the instruction options after the browser’s name:

Open Browser about:blank ${BROWSER} options=add_experimental_option(‘excludeSwitches’, [‘enable-logging’])

Try this and let us know.

1 Like