# SessionNotCreatedException: Message: session not created: Chrome failed to start: exited normally. (session not created: DevToolsActivePort file doesn't exist) (The process started from chrome location /usr/bin/chromium is no longer running, so Chrome

**URL:** https://forum.robotframework.org/t/sessionnotcreatedexception-message-session-not-created-chrome-failed-to-start-exited-normally-session-not-created-devtoolsactiveport-file-doesnt-exist-the-process-started-from-chrome-location-usr-bin-chromium-is-no-longer-running-so-chrome/6527
**Category:** Robot Framework
**Created:** [30 November 2023 15:41 UTC](https://forum.robotframework.org/t/sessionnotcreatedexception-message-session-not-created-chrome-failed-to-start-exited-normally-session-not-created-devtoolsactiveport-file-doesnt-exist-the-process-started-from-chrome-location-usr-bin-chromium-is-no-longer-running-so-chrome/6527 "2023-11-30T15:41:25Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![halimajredon](https://avatars.discourse-cdn.com/v4/letter/h/c4cdca/32.png) [@halimajredon](https://forum.robotframework.org/u/halimajredon)
#### Post date: [30 November 2023 15:41 UTC](https://forum.robotframework.org/t/sessionnotcreatedexception-message-session-not-created-chrome-failed-to-start-exited-normally-session-not-created-devtoolsactiveport-file-doesnt-exist-the-process-started-from-chrome-location-usr-bin-chromium-is-no-longer-running-so-chrome/6527/1 "2023-11-30T15:41:25Z")

</div>

Im currently facing some issue on my jenkins docker agent, trying to run the test cases there.  
Im getting this error:

- Cache folder (/home/jenkins/.cache/selenium) cannot be created: Permission denied (os error 13)
- SessionNotCreatedException: Message: session not created: Chrome failed to start: exited normally.
- (session not created: DevToolsActivePort file doesn’t exist)
- (The process started from chrome location /usr/bin/chromium is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
- Stacktrace:
- #0 0x56173f4edee3 
- #1 0x56173f1cb137 
- #2 0x56173f1fcdad 
- #3 0x56173f1f861b 
- #4 0x56173f2396d2 
- #5 0x56173f230663 
- #6 0x56173f203a45 
- #7 0x56173f204fb2 
- #8 0x56173f4c2a17 
- #9 0x56173f4c5b4d 
- #10 0x56173f4c55f8 
- #11 0x56173f4c6065 
- #12 0x56173f4b4d3f 
- #13 0x56173f4c63f2 
- #14 0x56173f49ee46 
- #15 0x56173f4dec65 
- #16 0x56173f4dee4b 
- #17 0x56173f4ed46f 
- #18 0x7f24a388e044 

Im installing the latest versions of these libraries:  
robotframework  
selenium  
robotframework-seleniumlibrary  
robotframework-robocop  
robotframework-libtoc  
robotframework-pabot  
robotframework-browser  
babel  
requests  
pycountry  
xmltodict  
names  
Pillow  
PyPDF2  
pdfplumber

The failure appears in the Open Browser kwd from SeleniumLibrary trying to run cases in headless.

After I downgraded these libraries, it started working again:  
robotframework==6.0.2  
selenium==4.9.1  
robotframework-seleniumlibrary==6.1.1

Could really use some support in this dept.  
Thanks beforehand

---

<div class="post-metadata">

### Author: ![damies13](https://dub1.discourse-cdn.com/flex005/user_avatar/forum.robotframework.org/damies13/32/623_2.png) [@damies13](https://forum.robotframework.org/u/damies13)
#### Post date: [1 December 2023 13:23 UTC](https://forum.robotframework.org/t/sessionnotcreatedexception-message-session-not-created-chrome-failed-to-start-exited-normally-session-not-created-devtoolsactiveport-file-doesnt-exist-the-process-started-from-chrome-location-usr-bin-chromium-is-no-longer-running-so-chrome/6527/2 "2023-12-01T13:23:25Z")

</div>

Hi Redon,

I would suggest this is your issue:

> [@halimajredon](#):
>
> Cache folder (/home/jenkins/.cache/selenium) cannot be created: Permission denied (os error 13)

This is not a robot framework issue, but rather a permissions / setup issue on your test machine.

You should give the user running the test create permissions (or ask your sys admin for help with that) to create that path.

Am I correct that the user running the test is called jenkins? If so it seems odd that they don’t have create permissions in their own user folder? Perhaps your admins have been a little too aggressive on the security policy?

Dave.
